Wake On Lan Problem beim "Kaltstart"

Dieses Thema Wake On Lan Problem beim "Kaltstart" im Forum "Netzwerk" wurde erstellt von wwWerkstatt.at, 21. Aug. 2014.

Thema: Wake On Lan Problem beim "Kaltstart" Servus zusammen! Habe mir WOL am alten XP-PC eingerichtet und dies scheint auch grundsätzlich zu funktionieren....

  1. Servus zusammen!

    Habe mir WOL am alten XP-PC eingerichtet und dies scheint auch grundsätzlich zu funktionieren. Allerdings lässt sich der PC aus dem Kaltstart heraus - also zB am frühen Morgen, nachdem er die Nacht über aus war - nicht über das Internet starten, sehr wohl aber aber das Heimnetz.
    War der PC schon mal an und ich fahre ihn herunter funktioniert auch das Starten aus dem Internet heraus wieder. Somit liegt´s wohl irgendwie am Kaltstart, wobei ich nicht verstehe, warum es im internen Heimnetz immer funktioniert...

    Ich verwende die Android-APP WakeOnLan.
    Windows XP SP3;
    Atheros AR8121/AR8113/AR8114 PCI-E als Netzwerkkarte (on board)

    Freue mich auf Eure Ratschläge, DANKE!

    Joe
     
    Zuletzt bearbeitet: 21. Aug. 2014
  2. Gute Frage...hat der PC eine feste IP? Diese mal auch im Router fest vergeben.
    Wenn der PC die IP via DHCP bekommt und der Lease abgelaufen ist kann der Router den PC mangels IP nicht anpingen und somit auch nicht aufwecken.

    Die IP des Routers bekommst ja vermutlich viy DynDNS o.ä.
     
  3. Hallo!

    Danke für Deine Antwort!
    Der PC bekommt eine feste IP vom Router. Mein Anschluss läuft mit fixer IP-Adresse.
    Wie gesagt:

    • Wenn der PC gerade erst runtergefahren wurde, klappt das WOL über meine Handy-App UND der Verbindung über das mobile Netzwerk.
    • Wenn der PC länger aus ist, dann funktioniert das nicht
    • Wenn der PC länger aus ist und ich aktiviere über mein Telefon bei Verbindung im Heimnetz dann klappt es immer

    Deshalb eben der Betreff mit dem Kaltstart - ich kann´s mir nicht anders erklären.

    Das Port-Forwarding ist so konfiguriert:
    * eingehende IP: 111.111.111.111 (=> meine DSL-Anbieter-IP)
    * eingehender Port: UDP 33600
    * dann weiter auf die PC-IP intern 192.168.0.21 via Port 9 NAT

    Der Router hat vom PC mittels MAC die Anweisung immer die selbe IP zu vergeben.

    Lokal ist eigentlich GAR NIX angepasst worden, das Wake-On hat auch ohne Forwarding im Router funktioniert:
    * 255.255.255.255:9


    So siehts bei mir aus... :)
     
    Zuletzt bearbeitet: 22. Aug. 2014
  4. Hat keiner von Euch eine weitere Idee?
    Leider komme ich selbst in dieser Sache nicht vom Fleck...
     
  5. Trage die feste IP bei deinen Rechner ein!

    Bei WOL ist die Übertragung der MAC-Adresse ebenfalls wichtig, nicht alle Router unterstützen das. Solange der Router die MAC des Rechners hat (Stichwort Lease!) klappt das auch.
    Daher mal den direkten Weg freimachen (DMZ=Demilitarisierte Zone)
     
  6. Das hat bestimmt nichts mit einer IP oder einer DMZ zu tun. DMZ ohnehin nicht; erstens hat das Prinzip wenig mit dem hier beschriebenen Problem zu tun und zweitens, ändert sich die Problemlage ja nicht, wenn der Rechner schon mal eingeschaltet war.

    Ausserdem beim Einschalten des PCs weiß der PC ja noch nichts von irgendwelchen IPs... das einzige was der PC beim Einschalten "anbieten kann" wäre seine MAC Adresse. Aber auch das kann nicht sein. Wir reden ja vom ausgeschalteten Zustand der auf "Ein" geschaltet werden soll. Da gibt es auch noch keine MAC Adresse, die der PC "anbieten" könnte.

    Der einzige Unterschied der mir spontan einfällt (aber ich bin kein Elektriker und daher können die das event besser beurteilen) ist der, das ein PC, der erst kürzlich herunter gefahren wurde, immer noch eine Restspannung hat. Bei manchen Problemen an der Hardware reicht nichteinmal das Abziehen des Stromkabels alleine, weil der PC noch genügend Restspannung vom Monitorkabel zieht. Nimmt man beide (oder auch allen anderen vorhandenen) Kabel weg, ist der PC wirklich Spannungsfrei.
    Ich könnte mir vorstellen, dass es damit etwas zu tun hat. Nachdem du den Rechner einmal hoch- und wieder heruntergefahren hast, ist noch eine Restspannung vorhanden und Du kannst ihn vom Internet aus hochfahren.

    Ich kann mir als Laie den Vorgang nicht 100%ig erklären - wie gesagt, mal einen Elektriker fragen; aber wenn Du wirklich nichts an der Konfiguration änderst, muß es ja an der Stromleitung bzw. am detektieren der ankommenden Spannung liegen, oder?
    Gruß
    Statler
     
  7. Sorry-so einen Blödsinn bzgl. WOL hab ich noch nie gelesen!

    Natürlcih spielt 1. die IP eine Rolle und 2. auch die MAC.
    Kommt auf den Router drauf an. Entscheidend ist dass es grundsätzlich funktioniert. Damit es auch dauerhaft funktioniert muss auch das sog. Magic Packet durchkommen-das machen die wenigsten Router.
    Daher der Tipp mit DMZ-da kommt halt alles durch...
     
  8. Ok, dann mag ich vielleicht daneben liegen...
    Kannst Du mir bitte als Laien erklären, wo der Unterschied zwischen einem erst kürzlich heruntergefahrenen und einen über Nacht ausgeschalteten PC liegt?
    Alle Einstellungen die ich kenne bezüglich DMZ, IP und MAC Adresse, alle Konfigurationen verhalten sich immer !!! gleich - egal ob ich den PC nur kurz ausschalte oder ob ich ihn länger ausgeschaltet habe.
    Laut der Fragestellung vom Anfang macht aber genau das den Unterschied.

    Du schreibst: 'Damit es auch dauerhaft funktioniert muss auch das sog. Magic Packet durchkommen-das machen die wenigsten Router. '
    Was hat das denn damit zu tun ob der Rechner gerade erst eingeschaltet war oder nicht?
    Entweder macht der Router das - oder eben nicht! Oder prüft ein solcher Router erst, ob die meissten PCs 'seines' Netzwerks gerade schon mal an waren - und wenn nicht, sagt er: 'Nö, dann spiele ich nicht mit. Schaltet ihr euch erstmal alle kurz ein.' ?

    Wenn Du mir das erklären kannst, gebe ich gerne zu, dass meine Idee Schwachsinn ist.... ansonsten halte ich Deine Idee für.....

    Gruß
    Statler
     
    Zuletzt bearbeitet: 26. Aug. 2014
  9. Wie bereits erwähnt: die LEASE-Zeit der IP-Adresse, welche an die MAC-Adresse gekoppelt wird. Daher benötigt der PC auch eine feste IP-Adresse.
    Ist der Rechner aus holt sich der keine neue sondern behält die, die er als letztes hatte-bis die LEASE-Zeit aus ist. Da das mit der festen IP durch den Router zugewiesen nicht immer klappt sollte man die IP beim PC selbst festlegen.
    Schon mal mit WOL / Magic Paketen / LEASE beschäftigt? Oder mit WOL als solches-wie sich das Netzteil verhält etc.?

    Mit einer beim PC festgelegten IP-Adresse sowie DMZ beim Router / Firewall sollte es auf jeden Fall klappen.
    Wobei man da noch unterscheiden muss zwischen Energie sparen und Ruhezustand!

    Befrag halt dazu mal Google und du wirst dich wundern wie komplex das Thema ist wenns nicht klappt!
    Ich kann nur sagen welche Vorraussetzungen man benötigt damit es überhaupt funktionieren kann. Ob die Hardware mitspielt oder Einstellungen nicht stimmen kann ich auf dem (virtuellen) Papier nicht sagen.

    Was du von mir oder meiner Aussage hältst ist für mich ehrlich gesagt genauso interessant wie in China ein Sack Reis umfällt.
    Ich bin FREIWILLIG hier um zu helfen - einen Elektriker zum Thema WOL zu befragen ist...egal.
    Einfach machen!
     
Die Seite wird geladen...

Wake On Lan Problem beim "Kaltstart" - Ähnliche Themen

Forum Datum
Problem mit erneutem Standby nach Wakeup unter Windows 7 Professional 64 Bit Windows XP Forum 16. Nov. 2010
WakeOnLan Problem Windows XP Forum 19. Sep. 2004
Wake on Lan im Ruhezustand - Funktioniert nicht. Windows 7 Forum 4. Sep. 2014
Wake over lan einrichten Firewalls & Virenscanner 30. Aug. 2011
Windows 7 64 Bit Ruhezustand defekt - lastwake meldet Netzschalter als Ursache Windows 7 Forum 4. Jan. 2010