Windows 7 64 Bit Ruhezustand defekt - lastwake meldet Netzschalter als Ursache

Dieses Thema Windows 7 64 Bit Ruhezustand defekt - lastwake meldet Netzschalter als Ursache im Forum "Windows 7 Forum" wurde erstellt von Qdc, 4. Jan. 2010.

Thema: Windows 7 64 Bit Ruhezustand defekt - lastwake meldet Netzschalter als Ursache Hallo. ich habe ein Problem mit dem Ruhezustand. Beim Versuch, in ihn zu wechseln, verdunkelt sich der Bildschirm,...

  1. Qdc
    Qdc
    Hallo.
    ich habe ein Problem mit dem Ruhezustand.

    Beim Versuch, in ihn zu wechseln, verdunkelt sich der Bildschirm, evtl. erscheint die Meldung, der Ruhezustand wird vorbereitet,
    und nach einer Sekunde ist Windows wieder an der Stelle, wo es war.
    Er wechselt nicht in Status S3. Der Versuch scheint sofort unterbrochen zu werden, nur ein kurzes Abblenden des Monitors gibts als Reaktion.
    Standby funktioniert, Herunterfahren auch.

    Ich meine mich zu erinnern, dass nach der Windows 7 Installation dieser noch funktioniert hat. Die Einstellungen "Ruhezustand" sind vorhanden,
    beim Drücken kommt der oben beschrieben Fehler.

    Hybrider Ruhezustand ist deaktiviert, die Hiberfil.sys Datei ist 4 gig groß ( auf 100% gestellt)
    und wurde bereits mehrfach mit powercfg -h on / off gelöscht und wiederhergestellt.

    Nun meine Vermutung:

    Gibt es irgendwelche Dienste oder Aufgaben, die einen Wechsel verhindern? Was wird erledigt oder könnte fehlen, dass ein solcher Wechsel nicht mehr funzt?


    Ausgabe powercfg -lastwake


    C:\Windows\system32>powercfg -lastwake
    Aktivierungsverlaufsanzahl - 1
    Aktivierungsverlauf [0]
    Aktivierungsquellenanzahl - 1
    Aktivierungsquelle [0]
    Typ: Schalter
    Netzschalter

    Ausgabe powercfg -a

    C:\Windows\system32>powercfg -a
    Die folgenden Standbymodusfunktionen sind auf diesem System verfügbar: Standby ( S3 ) Ruhezustand Hybrider Standbymodus
    Die folgenden Standbymodusfunktionen sind auf diesem System nicht verfügbar:
    Standby (S1) Die Systemfirmware unterstützt diesen Standbystatus nicht.
    Standby (S2) Die Systemfirmware unterstützt diesen Standbystatus nicht.

    Im übrigen scheinen S1 und S2 zu funktionieren

    Alle USB Geräte sind abgeschaltet und dürfen den PC nicht aus dem Sleep wecken.

    Falls jemand eine Idee hat, bitte melden!

    System:
    Windows 7 64 bit, aktuellster Stand
    Laptop
    Core2Duo P8700
    4 Gig Ram DDR3
    S-Ata HD
    Ati Radeon Mobility HD 4650 mit 512 Ram dezidiert
     
  2. Hallo,
    hast du all deine Treiber aktuell? Chipsatz, Grafik usw. ...
     
  3. Qdc
    Qdc
    Ja.

    Alle Treiber sind so aktuell wie auf dem Laptop möglich ( Es ist ein CompalBarebone).
    Einzige Änderung: Statt des "normalen" AMD / ATI Mobility Treiber
    wurde der Workaround für den Desktoptreiber angewendet worden (MobilityModder).

    Habe einige Tasks deaktiviert, deshalb meine Frage, ob ein Dienst oder eine Aufgabe dafür verantwortlich sein könnte.

    Wie gesagt, der Ruhezustand funktionierte nativ schon, ich kann leider auch nicht den genauen Termin festmachen, seit wann er nicht geht.
    Windows 7 ist erst seit Ende Dezember drauf, seitdem wurden viele Änderungen / Installationen und Updates getätigt.
     
  4. Qdc
    Qdc
    Nachtrag:
    Beim Versuch, von Hand in den Ruhezustand zu wechseln (shutdown /h /f)
    schenkt mir die Konsole nach dem Abblenden die Fehlermeldung

    C:\Windows\system32>shutdown /h /f
    Das System kann die angegebene Datei nicht finden.(2)

    Was mich wundert, da die Hiberfile da ist.

    Nachtrag:
    Nach googlen habe ich mal nach der Bcd geguckt:

    C:\Windows\system32> bcdedit
    Der Speicher für die Startkonfigurationsdaten konnte nicht geöffnet werden.
    Das System kann die angegebene Datei nicht finden.

    Ist das normal?
    Neben WIndows 7 ist i.ü. noch ein Ubuntu 9.10 drauf, mit Grub 2 als Bootmgr
     
  5. Qdc
    Qdc
    Neues von der Front,

    Mit BCdedit war ich auf der richtigen Spur.
    Nach etwas Recherche zu diesem Thema fiel mir auf, dass MSconfig mir keinerlei Informationen über meinen Systemstart zu geben vermag.
    Meine gesamte Bootkonfiguration war gelöscht (?) nicht zugänglich
    Also flugs eine WiederherstellungsCD gebrannt, das ganze automatisch wiederherstellen lassen.
    Fehler: bootsektor / Partitionstabelle des Laufwerks fehlerhaft
    jetzt gehts wieder.


    Meine Vermutung.
    Entweder Suse, vermutlich aber eher das neue Ubuntu hat mir meine partitionstabelle wieder einmal zerschossen.
    (War bei Ubunutu jedenfalls früher bei mir Gang und Gäbe).
    Da ja Windows gegen solche Fehler relativ resistent ist, (man kann ja auch mit nem inkonsistenten Dateisys leben),
    fiel das anscheinend beim hochfahren nie auf, gestartet wurde sowieso über GRUB
    Aber es sieht so aus, dass beim Wechsel in den Ruhezustand eben jene fehlende Startkonfigurationsdaten einen solchen Wechsel verhinderten, der Ruhezustand wurde abgebrochen.

    Problem Gelöst.
     
  6. Super Qdc,

    für manchen anderen User vielleicht auch von Interesse.

    Danke für die Info.,
     
  7. Hi,
    leider kam ich mit Deiner lösung nicht zum Ziel, habe aber eine andere Lösung gefunden.
    Auf meinem System existiert noch eine 100MB große Systempartition mit dem Bootmanager. Dieser war allerdings kein Laufwerksbustabe zugeordnet. Nachdem ich dort eine Zuordnung vorgenommen habe, funktionierte bcdedit wieder und auch der Ruhezustand.

    Gruß Prime1009
     
  8. Danke für die Info Prime

    Gruß Rossy
     
  9. Hallo zusammen,
    ich habe seid ein paar Tagen die gleichen Probleme, wie oben beschrieben.
    Meine gesamte Bootkonfiguration ist gelöscht (?) nicht zugänglich, irgendwie komme ich nicht mehr an den Bootloader ran. Die Lösung mit der Reparatur habe ich versucht, leider keinen Erfolg. Also habe ich wie prime009 einen Laufwerksbuchstaben für die 100mB Systempartition vergeben und siehe da, auf einmal kann ich wieder über "msconfig - Start" auf den Bootloader zugreifen.
    Aber das mit dem Buchstaben zuweisen ist in meinen Augen nur unbefriedigend, da ich dann dieses Laufwerk immer angezeigt bekomme. Also habe ich das Laufwerk ausgeblendet (Mountvol X: /D) und dacht nu wird alles ok sein. Dumm nur. das mit dem ausgeblendeten LW der Bootloader nach dem nächsten Start wieder nicht zu finden ist. Man merkt das im Betrieb nicht, Windows bootet, alles scheint zu funktionieren, nur wenn man in den Ruhezustand will, klappts nicht. Die Windows 7 Speicherdiagnose ist auch nicht ausführbar.
    Wenn ich das System in die Reparaturconsole starte und den MBR fixe kommen folgende Meldungen:

    bootrec /FixMBR
    -> Erfolgreich
    bootrec /FixBoot
    -> Element nicht gefunden
    bootrec /RebuildBcd
    -> Listet OS erfolgreich auf, meint aber bei eintippen von Ja(J) bzw. Alle(A)
    -> Element nicht gefunden

    bcdedit /create
    ->
    Der Speicher für die Startkonfigurationsdaten konnte nicht geöffnet werden.
    Das angeforderte Systemgerät kann nicht gefunden werden.
    Woran kann das jetzt noch liegen?

    Als letzten Akt habe ich nun die Partition, die den Bootloader installiert hat, mit Paragorn Backup&Recovery aus einer alten Sicherung wiederhergestellt, leider kein Erfolg.

    Kann mir irgendjemand helfen ?

    MfG

    Mr. Jangles
     
  10. Nun du könntest den Bootloader auch auf C: verlegen. Dafür einfach c: auf Aktiv setzen dann von DVD Starten und die von dir gemachten Befehle Wiederholen ( fixmbr und fixboot) dann kannst du die 100MB große Part. löschen. Den alles was dort noch drauf ist hat die DVD auch quasi Automatische Reparatur usw.


    Gruß Rossy
     
Die Seite wird geladen...

Windows 7 64 Bit Ruhezustand defekt - lastwake meldet Netzschalter als Ursache - Ähnliche Themen

Forum Datum
Ruhezustand funktioniert nicht, Windows Bootfehlermeldung Windows XP Forum 1. Jan. 2012
Windows 7 (64bit) wacht nicht mehr aus Ruhezustand auf Windows 7 Forum 19. Jan. 2011
Windows 7 Ruhezustandsprobleme Windows 7 Forum 2. Juli 2010
Windows 7 geht ab und zu über Nacht in Ruhezustand Windows 7 Forum 8. Juni 2010
(Un-)Ruhezustand bei Windows Vista Windows Vista Forum 3. Juli 2008