WSUS/SUS-Problem

Dieses Thema WSUS/SUS-Problem im Forum "Windows Server-Systeme" wurde erstellt von RouvenE, 3. Sep. 2007.

Thema: WSUS/SUS-Problem Hallo, Ich habe vor 1 Woche WSUS installiert. Nun hatte ich die glorreiche Idee, WSUS zu installieren, um es erneut...

  1. Hallo,

    Ich habe vor 1 Woche WSUS installiert. Nun hatte ich die glorreiche Idee, WSUS zu installieren, um es erneut sauber zu installieren. Leider ergab die Deinstallation einen Fehler.
    Eine neue Installation will WSUS erst mit einer Deinstallation beginnen, die erneut mit dem Fehler abbricht. Somit kann ich kein funktionsfaehiges WSUS 3.0 installieren. Kann mir jemand helfen ? Wie installiere ich es erneut ? Evtl. Optionen, die vorhandene Installationsreste reparieren ?

    Deswegen habe ich SUS (Software Update Service) installiert. Leider kann ich nicht http://MYDOMAIN/SUSAdmin erreichen, da mit die Rechte (als Administrator eingeloggt) fehlen wuerden.
    Wo bitte muss ich wie das erforderliche Recht setzen ?

    Danke
     
  2. Runter mit SUS. Welche Fehlermeldung kommt bei der Deinstallation des WSUS?
    Hast du die WMSDE installiert oder nen eigenen SQL-Server?
     
  3. Hallo,

    WSUS meldet bei der Deinstallation Es ist ein Fehler aufgetreten. ... sehr vielsagend.
    Bei der Installation, die nun nur noch startet, meint das Programm, es sei eine neuere Version installiert.

    Installationsparameter /u oder /o bringen auch keine Besserung.

    SQL laeuft nicht, daher hat glaube ich WSUS bei der vorher noch funktionierenden Installation eine Database installiert.
    Aber SQL kann ich mir auch von MS besorgen und kurz installieren.

    Was WMSDE ist, weiss ich grad leider nicht.
     
  4. WMSDE ist eine lokale Datenbank von Microsoft.
     
  5. Leider faengt WSUS bei jedem Aufruf der Installationsdatei an, eine Deinstallation zustarten, die abrupt endet:

    Hier meine LOG-Datei...

    2007-09-08 11:50:59 Success MWUSSetup Validating pre-requisites...
    2007-09-08 11:51:06 Success MWUSSetup Removing Wsus...
    2007-09-08 11:51:07 Success CustomActions.Dll Successfully set propery of WSUS admin groups' full names
    2007-09-08 11:51:23 Error CustomActions.Dll CSqlConnection::Open: Failed to open SQL connection to instance MOS-SERVER\MICROSOFT##SSEE (Error 0x80004005: Unbekannter Fehler)
    2007-09-08 11:51:23 Error CustomActions.Dll GetDatabaseLocation: Failed to open connection to SQL instance %computername%\MICROSOFT##SSEE (Error 0x80004005: Unbekannter Fehler)
    2007-09-08 11:51:23 Error CustomActions.Dll SetWyukonInstallDirProperty: Failed to get installed location of SUSDB in WYukon (Error 0x80004005: Unbekannter Fehler)
    2007-09-08 11:51:23 Error CustomActions.Dll SetUnInstallProperties: Failed to set WYUKON install directory (Error 0x80004005: Unbekannter Fehler)
    2007-09-08 11:51:24 Error MWUSSetup RemoveWsus: MWUS Uninstall Failed (Error 0x80070643: Schwerwiegender Fehler bei der Installation.)
    2007-09-08 11:51:24 Error MWUSSetup Wsus MSI uninstallation failed. (Error 0x80070643: Schwerwiegender Fehler bei der Installation.)
    2007-09-08 11:51:24 Error MWUSSetup CSetupDriver::LaunchSetup: Setup failed (Error 0x80070643: Schwerwiegender Fehler bei der Installation.)
    2007-09-08 11:51:27 Error MWUSSetup DoInstall: Wsus setup failed (Error 0x80070643: Schwerwiegender Fehler bei der Installation.)

    Was meint Ihr ? Wie kann man den Fehler beheben ?
     
  6. Hallo,

    Ich habe WSUS 3.0 nun frisch installiert, ebenso Active Directory.

    Leider meint WSUS beim Verbinden mit einem Server aus der Konsole heraus, dass ich nicht die noetigen Rechte haette bzw. nicht der Gruppe WSUS-Administratoren angehoeren wuerde.

    Jedoch habe ich den eingeloggten Benutzer Administrator dieser Gruppe zugeordnet.

    Wo liegt der Fehler ?
     
  7. Kannst du dich denn am WSUS-Server direkt per Browser anmelden?
     
  8. Hm, nein... http://[SERVERNAME] reagiert nicht, aber ab WSUS 3.0 glaube ich, gibt es den Browserzugriff doch nicht mehr ?!