XP und 98 zusammen im Netzwerk

Dieses Thema XP und 98 zusammen im Netzwerk im Forum "Netzwerk" wurde erstellt von longridge, 5. Mai 2004.

Thema: XP und 98 zusammen im Netzwerk Liebe Winto-taler... ich habe seit einiger Zeit einen XP-Rechner und 3 98-er Systeme mit einem Router und ADSL...

  1. Liebe Winto-taler...

    ich habe seit einiger Zeit einen XP-Rechner und 3 98-er Systeme mit einem Router und ADSL vernetzt. (3 Teenies am Abitur)

    Anfänglich lief dies sehr gut, doch seit 2 Wochen will die XP-Maschiene nicht mehr so recht im LAN mitmachen. Verschiedenste Versuche haben ab und zu ganz kurz mal u.a. totalen Erfolg gehabt, es konnte aber auch sein dass nur ein einzelner der 98-Rechner die Kommunikation wieder aufnahm, aber nach einiger Zeit läuft dann wieder gar nichts mehr. Die 98er kommunizieren bestens zusammen, der Internetzugang stellt ab keiner Maschine ein Problem dar.

    Die Sache mit dem automatischen Heimnetzwerk hilft in den meisten Fällen gar nicht.

    Der auf XP erhältliche Test bleibt immer bei 99% stehen. Resultate habe ich noch keine gesehen.

    Die Reparatur der LAN-Verbindung wird prompt durch XP erledigt, ohne Ergebnis.

    Auf der DOS-Ebene Antworten die 98er auf den Ping und auf Net view.

    SASSER habe ich auch nicht gemäss Symantec-Fix

    Vielen Dank für den einen oder anderen Hinweis,

    l. :-[
     
  2. Hi,

    ich verstehe deine Frage nicht so ganz.
    Können die 98er nicht auf den XP-Rechner zugreifen?
    Kann der XP-Rechner auf keinen der 98er zugreifen?
    Sind alle Rechner in der gleichen Arbeitsgruppe? Identische Schreibweise beachten.
    Beziehen die Rechner ihre IP-Adresse über DHCP?
    Ist die einfache Dateifreigabe bei XP deaktiviert?

    Poste doch mal bitte die IP-Konfig von deinen Rechnern.
     
  3. Ciao bla,

    vielen Dank dass Du Dir für mich Zeit nimmst. Was ich fragen will, tja, wenn ich dies genau formulieren könnte, am ehesten wäre mir mit einem Diagnoseprogramm geholfen, denn das auf XP mitgelieferte wird nie fertig, und mit den Fehlermeldungen kann ich nichts anfangen, da meiner Meinung nach die Einstellungen (Computername und Arbeitsgruppe, der eine je nach Maschine anders, die andere überall gleich) korrekt sind.

    Also, auf den 98er wird bei Abfrage der Netzwerkumgebung alles angezeigt was gerade eingeschaltet ist. Öffne ich aber den Ikon des XP, der ab und zu erscheint, oder eben auch nicht, kommt folgende Meldung:

    Auf \\wrap kann nicht zugegriffen werden.

    Überprüfen Sie den Namen und die Schreibweise und wiederholen Sie den Vorgang.


    Der XP zeigt gar keinen Arbeitsgruppencomputer an, und meldet:

    Auf Meier kann nicht zugegriffen werden. Sie haben eventuell keine Berechtigung, diese Netzwerkresource zu verwenden. Wenden Sie sich and den Administrator des Servers, um herauszufinden ob Sie über Berechtigungen verfügen.

    Die Liste der Server in dieser Arbeitsgruppe ist zurzeit nicht verfügbar.



    Meine Rechner sind an einem über einen Switch/Router miteinander, respektive mit dem Internet verbunden, dieser teilt auch die IP's zu, was auf DOS-Ebene mit ping und net view kontrolliert werden kann. Die IP-Bereiche sind auch auf der Internet-Security von Symantec korrekt freigegeben. Die Konfiguration posten bringt in diesem Fall leider eher wenig.

    Dateifreigabe bei XP, tja, wenn Du das meinst mit den Händchen an den Ikons, dies habe ich genau gleich wie bei den 98er gemacht.

    Ich habe eher das Gefühl dass seit irgendeinem Update, oder eben doch ein Virus, sich irgendwas geändert hat.

    Ich bin nicht wirklich sattelfest in Computerdingen, benutze die Kisten lieber für andere Sachen, bin aber der Mechaniker in der Familie. Das Netzwerk hat bis vor kurzem relativ problemlos gearbeitet, aber seit kurzem bin ich am Schattenboxen.

    Ein Hinweis vielleicht: In der Systemsteuerung auf System und Computername ist der Name mit einem Punkt am Schluss aufgeführt, ich kann dies zusammen mit dem Arbeitsgruppennamen (sonst kommt der OK-Switch nicht) zwar ändern, aber der Punkt erscheint danach immer wieder. Könnte es etwas damit zu tun haben? Da ich nur eine XP-Maschine habe kann ich nicht quervergleichen.

    Auf alle Fälle vielen Dank nur schon für's Durchlesen,

    l. ???
     
  4. Ich habe noch kein Diagnoseprogramm benutzt und das von XP kenne ich nicht.
    Deswegen solltest Du ja die IP-Kofig deiner Rechner hier poste,
    Wobei es reichen müsste wenn Du die von deiner XP-Maschine nimmst und eine von deinen 98er.
    Für den XP-Rechner: Start - Ausführen - Eingabe von cmd - in der Komandozeile dann Eingaben von ipconfig /all

    Für die 98er: Start - Ausführen - Eingabe von command - in der Komandozeile dann Eingaben von ipconfig /all

    Da Du deine Rechner über einen Router vernetzt hast solltest Du wohl die Hosts-File anpassen.
    Siehe hier
    Kannst Du über die IP-Adresse auf die 98er-Rechner zugreifen?

    Hast Du den Zugriff auch schon mal mit deaktivierter Firewall probiert?

    Bei der Frage zur einfachen Dateifreigabe war nicht das Händchen unter dem freigegebenen Verzeichnis gemeint, sonder die Funktion von XP, das alle Rechner die sich im Netz anmelden auf die Freigaben zugreifen dürfen.

    Alle Rechner müssen nicht nur der identischen Arbeitsgruppe angehören sondern auch im selben Subnet sein, eins von beiden scheint auf deinem XP-Rechner nicht zuzutreffen.
    Am besten wäre es wenn Du die IP-Kofigurationen deiner Rechner posten würdest.

    Da ich keine XP-Maschine hier habe kann ich das so nicht nachvollziehen.
    Hört sich aber merkwürdig an.

    Sollte sich vielleicht mal einer der Netzwerkfreaks zu äußern ;)
     
  5. Hallo bla,

    ich bin überwältigt von Deiner umfassenden Antwort.
    Das Diagnoseprogramm von XP hat mittlerweilen auch seinen Geist aufgegeben, steht jetzt regelmässig bei 0% schon still, tolle Sache, Big Bill...

    Mittlerweilen habe ich auch mitbekommen wie das mit ipconfig läuft, also, hier sind sie:

    Der XP:

    Hostname. . . . . . . . . . . . . : WRAP
    Primäres DNS-Suffix . . . . . . . :
    Knotentyp . . . . . . . . . . . . : Unbekannt
    IP-Routing aktiviert. . . . . . . : Nein
    WINS-Proxy aktiviert. . . . . . . : Nein

    Ethernetadapter LAN-Verbindung:

    Verbindungsspezifisches DNS-Suffix:
    Beschreibung. . . . . . . . . . . : 3Com Gigabit LOM (3C940)
    Physikalische Adresse . . . . . . :############
    DHCP aktiviert. . . . . . . . . . : Ja
    Autokonfiguration aktiviert . . . : Ja
    IP-Adresse. . . . . . . . . . . . : 192.168.1.35
    Subnetzmaske. . . . . . . . . . . : 255.255.0.0
    Standardgateway . . . . . . . . . : 192.168.1.1
    DHCP-Server . . . . . . . . . . . : 192.168.1.1
    DNS-Server. . . . . . . . . . . . : 192.168.1.1
    Lease erhalten. . . . . . . . . . : Freitag, 7. Mai 2004 07:46:07
    Lease läuft ab. . . . . . . . . . : Montag, 10. Mai 2004 07:46:07

    Ethernetadapter Netzwerkbrücke (Netzwerkbrücke) 14:

    Verbindungsspezifisches DNS-Suffix:
    Beschreibung. . . . . . . . . . . : MAC-Brückenminiport
    Physikalische Adresse . . . . . . : #############
    DHCP aktiviert. . . . . . . . . . : Ja
    Autokonfiguration aktiviert . . . : Ja
    IP-Adresse (Autokonfig.). . . . . : ############
    Subnetzmaske. . . . . . . . . . . : 255.255.0.0
    Standardgateway . . . . . . . . . :


    Und nun einer der 98er:

    Hostname . . . . . . . . . : COMPI
    DNS-Server . . . . . . . . : 192.168.1.1
    Knotentyp . . . . . . . . . : Broadcast
    NetBIOS-Bereichs-ID . . . . :
    IP-Routing aktiviert. . . . : Nein
    WINS-Proxy aktiviert. . . . : Nein
    NetBIOS-Auflösung mit DNS . : Nein

    0 Ethernet Adapter :

    Beschreibung. . . . . . . . : PPP Adapter.
    Physische Adresse . . . . . : ############3
    DHCP aktiviert. . . . . . . : Ja
    IP-Adresse. . . . . . . . . : 0.0.0.0
    Subnet Mask . . . . . . . . : 0.0.0.0
    Standard-Gateway . . . . . . :
    DHCP-Server . . . . . . . . : 255.255.255.255
    Erster WINS-Server . . . . :
    Zweiter WINS-Server . . . :
    Gültig seit. . . . . . . :
    Gültig bis . . . . . . . :

    1 Ethernet Adapter :

    Beschreibung. . . . . . . . : Intel(R) PRO PCI Adapter
    Physische Adresse . . . . . : ##############
    DHCP aktiviert. . . . . . . : Ja
    IP-Adresse. . . . . . . . . : 192.168.1.34
    Subnet Mask . . . . . . . . : 255.255.0.0
    Standard-Gateway . . . . . . : 192.168.1.1
    DHCP-Server . . . . . . . . : 192.168.1.1
    Erster WINS-Server . . . . :
    Zweiter WINS-Server . . . :
    Gültig seit. . . . . . . : 07.05.04 08:27:31
    Gültig bis . . . . . . . : 10.05.04 08:27:31

    Das mit den Hosts File anpassen scheint mir auch etwas zum ausprobieren zu sein. Könntest Du dies etwas näher erläutern, ich finde zwar einen Hosts-File, kann ihn mit Word öffnen, aber es scheint mehr sowas wie ein Beispiel zu sein!

    Ein mittlerweilen kontaktierter Kollege hat mir den Trick gezeigt mit der IP-Adresse im Internet Explorer, dies funktioniert, wenn auch nur in einer Richtung, ab dem XP auf die 98er ganz gut.

    Deaktivierte Firewall brachte kein Erfolg.

    Wahrscheinlich lehne ich mich etwas weit aus dem Fenster wenn ich meine dass auf XP sowas wie auf den 98ern (allgemeine Freigabe von Dateien und Druckern) nicht gibt. Aber die einzelnen Files kann man freigeben. Und der Drucker hat früher auch von den 98ern benützt werden können.

    Wenn es sowas gibt, kann mir da ein XP-Experte weiterhelfen?

    Die Geschichte mit dem Punkt nach dem Computernamen war auch meinem kontaktierten Kollegen etwas suspekt, vielleicht trotzdem irgend ein Käfer?

    Ich habe in Wintotal ja Beispiele Gefunden wo nach Reinigung mit Adaware, oder nach deinstallation von irgendwelchen Programmen die Sache wieder lief.

    Auf alle Fälle vielen Dank,

    l.
     
  6. Super, das scheint dann ein DNS-Problem zu sein, da der Zugriff über die IP-Adresse funktioniert.
    Abhilfe sollte eine agepasste Hosts schaffen.
    Öffne bitte die Datei Hosts mit dem Editor und füge die im Netzwerk vorhandenen Rechner mit IP-Adresse und Namen hinzu. Zur Zeit dürfte da nur der Localhost drin stehen.

    Zum Zugriff von den 98er auf den XP:
    Welche Meldung bekommst Du denn wenn Du über die IP-Adresse zugreifst?
    Kontrollier doch bitte ob die einfache Dateifreigabe deaktiviert ist.
    Klick auf dem folgenden Link
    Microsoft
    Wenn Du sie deaktiviert haben möchtest,was ich empfehlen würde, müssen alle Benutzer von den 98er Rechnern auf dem XP-Rechner lokal angelegt werden.
    Dabei ist die identische Schreibweise zu beachten.

    Die IP-Konfig sieht für mich OK aus.
    Denke aber das Du die Netzwerkbrücke am XP wieder entfernen kannst.
     
  7. Hallo bla,

    dann bin ich ja froh mich bei Dir mit meinen Angaben nicht total bla-miert zu haben.

    Nun, die einfache Dateifreigabe (ich kann mich nicht erinnern da mal was rumgeschraubt zu haben, ist aber schon möglich, mein Biocomputer macht laufend datadrain...) war richtig gesetzt.

    Die Sache mit dem hosts file habe ich auch hingekriegt (war'n komisches Gefühl, ich fürchte immer wenn ich so in den Eingeweiden des BS rumschnippsle läuft bald gar nichts mehr, oder die Kiste fliegt mir um die Ohren)
    Nun, jetzt bringt der XP die IP-Nummern und die Namen zusammen, und die Netzwerkumgebung ist auch wieder aufgetaucht, ich habe sogar einige Platten auf den 98ern als Netzwerkressourcen einrichten können. Aber Hostcomputer will der XP immer noch keine finden, selbe Antwort wie gestern beschrieben.

    Frage: Teilt den der Router immer dieselben IP-Nummern dem gleichen Computer zu? Müsste er doch, sonst gibts ein Durcheinander das nächste mal beim Aufstarten.

    Äh, ja, und von den 98ern kommt beim Schreiben der IP-Adresse des XP immer noch die Antwort:

    Die Datei \\192.168.1.35 wurde nicht gefunden. Überprüfen Sie die Schreibweise und wiederholen Sie den Vorgang, oder suchen Sie die Datei, indem Sie auf Start und anschliessend auf Suchen klicken.

    Und nun mal was Grundsätzliches, ich finde das ausserordentlich toll dass Du mir so weiterhilfst. :)
    Wieso aber so was unstabiles wie XP auf die Welt losgelassen wird, :mad: verstehe ich nicht. Hatte beim einrichten eine grössere Geschichte mit JAVA, aber da kann ich leben damit (zum Glück gibt's noch W98...)

    viele Grüsse, und schönes Wochenende,

    l.
     
  8. Hi longridge,

    hab mir nochmal dein erstes Posting durchgelesen.
    Da steht
    Wie verhält es sich denn umgekehrt? Wenn Du vom 98er einen Ping auf den XP setzt.
    Ist eigentlich die XP eigene Firewall deaktiviert?

    Was meinst Du damit? Stehe gerade auf dem Schlauch ;D

    Gute Frage. Habe das erst einmal über einen Router gemacht. Und bei diesem war es so das immer die selben IP vergeben wurden. Bin mir aber nicht sicher das das immer so ist. Bin halt kein NW-Freak ;)
    Im zweifelsfalle die IP-Adressen fest zuweisen und das dürfte bei 4 Rechnern auch nicht das Problem sein, oder?
    Zur Namensauflösung gibt es m.E. auch noch ein Protokol namens NetBEUI. Kannst dich ja mal bei Gelegenheit darüber belesen.

    Das mit XP ist ja so ne Sache, aber stabilert als 98 ist es.

    Man kann XP nun mal nicht mit 98 vergleichen. Eher mit 2000, aber das gefällt mir wesentlich besser.

    Wünsche auch Dir ein schönes Wochenende
     
  9. Ciao Bla,


    nein, nicht schon wieder, vom pingen und net viewen habe ich langsam genug, aber, neuer Tag, neues Spiel, neues Glück...

    Also, ich habe heute wegen jugendlicher Bettflucht langeweile, fahre alle PC's hoch und pinge drauflos, nichts geht mehr.

    Was hast Du empfohlen, Firewalls und NetBEUI.

    Ich schalte das ADSL-Modem aus, fahre alle Firewalls hinunter und siehe da, es pingt wieder, aber, nur noch die 98er untereinander. Nun ich fahre die Firewalls wieder hoch, und, wenn nur noch der XP ohne Firewall im Netz ist, gibt er den 98ern auch wieder Antwort. Komisch...Nun versuche ich es in den Firewall Einstellungen (NIS!) und richte das Netzwerk nochmals ein, und siehe da, plötzlich sind da nicht mehr nur ein Adressbereich, sondern auch ein Netzwerk unter Vertrauenswürdig aufgeführt...

    Und plötzlich funktioniert das Netzwerk wie früher, auch Internet natürlich, nach dem Einschalten des ADSL-Modems.

    NetBEUI, nein danke, never touch an again running System...

    Da scheint es mir aber gleich mehrere Kombinationen von Bugs mitgespielt zu haben....

    Auf alle Fälle vielen Dank, bla, und alles Gute,

    l. :) :) :)
     
  10. hp
    hp
    netbeui ist nicht routigfähig und da du ja einen router besitzt bringt dir netbeui nichts. bla meine wahrscheinlich netbios over tcp, daß im gegensatz zu netbeui sich an tcp bindet und dadurch routingfähig wird. die einstellung wird eigentlich standardmäßig an der lankarte aktiviert, kannst du aber überprüfen über netzwerkumgebung, tcp/ip, eigenschaften, erweitert wins. netbios over tcp sorgt für das sehn der freigegebenen ressourcen in einem windowsnetz...

    greetz

    hugo
     
Die Seite wird geladen...

XP und 98 zusammen im Netzwerk - Ähnliche Themen

Forum Datum
[GELÖST]Netzwerk bricht zusammen Firewalls & Virenscanner 31. Aug. 2009
Verbindung zu Netzwerkspeicher bricht zusammen Windows XP Forum 26. Feb. 2006
Netzwerk bricht zusammen Windows XP Forum 7. Aug. 2005
2 Netzwerke mit 2 Routern zusammenlegen Netzwerk 12. Mai 2004
Partition zusammenführen Windows XP Forum 9. Feb. 2016