Excel: Monats-Vorkommen in Datumsspalte zählen

Dieses Thema Excel: Monats-Vorkommen in Datumsspalte zählen im Forum "Microsoft Office Suite" wurde erstellt von Ace_NoOne, 20. Sep. 2005.

Thema: Excel: Monats-Vorkommen in Datumsspalte zählen Hallo zusammen, ich habe eine Spalte, in der die Startdaten bestimmter Termine angegeben sind. Nun möchte ich eine...

  1. Hallo zusammen,

    ich habe eine Spalte, in der die Startdaten bestimmter Termine angegeben sind. Nun möchte ich eine Übersicht erstellen, welche die Vorkommen dieser Termine in bestimmten Monaten angibt. Das Ganze soll sieht ungefähr so aus:
    Tabellenblatt 1: Daten in Spalte E (Zeilen 2-77)
    Tabellenblatt 2: Spalten für Jahr, Monat und Häufigkeit - letztere soll eben wiedergeben, wie oft der jeweilige Monat des entsprechenden Jahres in Tabellenblatt 1 vorkommt.

    Ich habe es mit ZÄHLENWENN()[sup]1[/sup] sowie mit SUMMENPRODUKT()[sup]2[/sup], jeweils in Kombination mit MONAT(), versucht, aber irgendwie haut's nicht hin...

    Für hilfreiche Hinweise wäre ich dankbar!

    [sup]1[/sup] z.B. =ZÄHLENWENN(Tabelle1!E:E;MONAT(Tabelle1!E:E) = 4) - hier müsste ich bei MONAT() Zugriff auf den jeweils aktuellen Wert haben, denn einfach nochmals den Bereich angeben, funktioniert nicht
    [sup]2[/sup] z.B. =SUMMENPRODUKT(((MONAT(Tabelle1!$D2:$D77)=4)*(JAHR(Tabelle1!$E2:$E77)=2005)))
     
  2. hallo,

    hast du das ganze mal mit->summewenn' versucht? damit kannst du abhängigkeit zum datum herstellen.

    gruß,
    kath.hundefriseursalon
     
  3. Das mit dem Datum in Excel ist immer so eine Sache.

    Mach dir eine Hilfsspalte F: =JAHR(E1)&MONAT(E1)
    Blatt 2:
    Spalte A = Jahr,
    Spalte B = Monat
    Spalte C: =ZÄHLENWENN(Tabelle1!F:F;Tabelle2!A1&Tabelle2!B1)
     
  4. @kath: Mit SUMMEWENN ist's das gleiche Problem wie bei ZÄHLENWENN (glaube ich zumindest... ).

    @klexy: Daran hab' ich auch schon gedacht, hielt es aber für eine wenig elegante Lösung.
     
  5. Hallo Matjes,

    vielen Dank für das Angebot. Aber das kann ich kaum verlangen, zumal ich dich schon zu oft für meine Zwecke missbraucht habe... :eek: Wirklich wichtig ist's auch nicht (mehr).
    Wenn du allerdings Übung brauchst, kann ich dich natürlich nicht davon abhalten - und schaden würde es mir sicherlich nicht (deine Makros sind immer sehr lehrreich)..
     
  6. Ts, ts, ts... wenig elegante Lösung - ich bin empört! ;D
    Alter Hausfrauentrick! Funktioniert immer.

    Bei SUMMEWENN und ZÄHLENWENN gleichermaßen. Das liegt an der Art, wie Excel ein Datum verwaltet. Nämlich als reinen Zahlenwert, und zwar als Anzahl der Tage, die seit dem 01.01.1900 verstrichen sind. Dabei ist es wurscht, um welchen Monat es sich handelt. Erst das Ergebnis wird als Datum dargestellt. Im Prinzip eine Formatierungsfrage. Wenn du eine Zahl als Währung formatierst, werden die Euro rechnerisch auch nicht wirklich berücksichtigt, sondern nur der reine Zahlenwert.

    Aus genau diesem Grund hat Excel auch Schwierigkeiten, negative Zeiten und negative Tage (also -10, was eigentlich der 21.12.1899 sein müsste) darzustellen bzw. zu erkennen.
     
Die Seite wird geladen...

Excel: Monats-Vorkommen in Datumsspalte zählen - Ähnliche Themen

Forum Datum
Excel-Feature gesucht Microsoft Office Suite 11. Okt. 2016
Excel Tabelle Werte zu ordnen Microsoft Office Suite 23. Sep. 2016
Excel: Bereiche auf 'leer' Überprüfen Microsoft Office Suite 15. Sep. 2016
Import Datensatz inkl = und - Zeichen in Excel/Libre CALC Software: Empfehlungen, Gesuche & Problemlösungen 20. Mai 2016
Bestimmter User kann seine Excel Dateien nicht mehr direkt öffnen Software: Empfehlungen, Gesuche & Problemlösungen 16. Apr. 2016