Excel: SVERWEIS funktioniert nicht

Dieses Thema Excel: SVERWEIS funktioniert nicht im Forum "Microsoft Office Suite" wurde erstellt von falcon30, 18. Jan. 2008.

Thema: Excel: SVERWEIS funktioniert nicht Hallo Zusammen, ich habe ein WS in der einige 100 einträge existieren. Im WS XY habe ich folgende Formel:...

  1. Hallo Zusammen,

    ich habe ein WS in der einige 100 einträge existieren.

    Im WS XY habe ich folgende Formel: =SVERWEIS(S26;$A$1:$N$224;4;Falsch).
    Ergebnis: #NV

    Wenn ich die Formel ändere: =SVERWEIS(S26;$A$1:$N$224;4;WAHR)
    Ergebnis ist dann #NV oder irgend ein Wert aus der entsprechenden Spalte.

    Was stimmt nicht?

    Vielen Dank im Voraus!!

    Grüße
    falcon30
     
  2. Hallo falcon,

    der 4.Parameter->Bereich_Verweis' gibt an, ob mit SVERWEIS ungefähr oder genau gesucht werden soll. Ín der Excel-Hilfe zu SVERWEIS ist das ausführlicher beschrieben.

    Gruß Matjes :)
     
  3. Hi Matjes,

    die Formel funktioniert, wenn ich sie in einer anderen Datei anwende.
    Ich weis nicht warum die Formel in der einen DAtei nicht funktioniert.

    Für vorschläge wäre ich sehr dankbar.

    Grüße
    falcon30
     
  4. Hallo falcon30,

    probier doch mal aus, welche Begriffe
    Code:
    =SVERWEIS(S26;$A$1:$N$224;4;Falsch)
    findet, in dem du in S26 z.B. den Begriff aus A1 speicherst, dann A50, A100, A150, A200, A224.

    Desweiteren könntest du über die Suchfunktion den Begriff aus S26 mit der Suchfunktion in A1:A224 versuchen zu finden.

    Schau mal was da rauskommt ?

    Es könnte auch sein, dass dein S26 einen Text darstellt, und in der Matrix nur Zahlen vorhanden sind. Dann match das auch nicht (oder umgekehrt). Formatierung sollte zusammenpassen (Ax zu S26).

    Gruß Matjes :)
     
  5. Hi Matjes,

    klappt irgendwie nicht.
    Ich habe alle Zellen auf Standard formatiert, um zu testen, aber ohne erfolg.

    Grüße
    falcon30
     
  6. Hallo falcon30,

    es ist etwas wie->im Trüben fischen'.

    Kannst Du mal für die ersten 3 Werte konkret werden ?

    zu
    'Standard' ist eben gerade kein Format (entspricht Variant).
    Da kann Excel machen, was es will.

    Umformatieren hilft so einfach auch nicht. Bei Umformatieren wird der vorher gespeicherte Wert erst geändert, wenn die Zelle aktiviert wird.

    Gruß Matjes :)

    ps: kannst mir ein Beispiel schicken, dass nicht funktioniert. Dann schau ich mal woran es liegt.
     
  7. Hallo Matjes,

    so sieht die Tabelle aus:

    KeKo 100N C4 10% 25V SMD 600.127.011 X7R 100N-0402 C0402-R 0,19 40 23 0,41 1 1 1 1 1 1 0,08
    KeKo 68N C5 10% 50V SMD 600.159.011 68N/50V-0805 C0805-R 0,19 40 23 0,41 0,45 1 1 1 1 1 0,04
    KeKo 10N C6 10% 25V SMD 600.137.011 X7R 10N-0402 C0402-R 0,19 40 23 0,41 1 1 1 1 1 1 0,08
    KeKo 100N C7 10% 25V SMD 600.127.011 X7R 100N-0402 C0402-R 0,19 40 23 0,41 1 1 1 1 1 1 0,08
    KeKo 100P C8 5% 25V SMD 600.123.011 NP0 100P-0402 C0402-R 0,12 40 23 0,41 1 1 1 1 1 1 0,05
    KeKo 100P C9 5% 25V SMD 600.123.011 NP0 100P-0402 C0402-R 0,12 40 23 0,41 1 1 1 1 1 1 0,05
    KeKo 68N C10 10% 50V SMD 600.159.011 68N/50V-0805 C0805-R 0,19 40 23 0,41 0,45 1 1 1 1 1 0,04
    KeKo 100N C11 10% 25V SMD 600.127.011 X7R 100N-0402 C0402-R 0,19 40 23 0,41 1 1 1 1 1 1 0,08
    KeKo 68N C12 10% 50V SMD 600.159.011 68N/50V-0805 C0805-R 0,19 40 23 0,41 0,45 1 1 1 1 1 0,04

    Die Tabelle hat 21 Spalten und 220 Zeilen.

    =SVERWEIS(A5;Stückliste!A4:U224;11;FALSCH)

    Spalte 11 und 22 sind von interesse.

    Grüße
    falcon30
     
  8. Hallo Falcon,

    hier geht es nur um die 1 Spalte der Matrix Stückliste!A4:A224.
    In dieser soll der Begriff , der in A5 steht gefunden werden.

    Was steht in A5 ?

    Ist dieser Begriff mit der Suchfunktion in Stückliste!A4:A224 zu finden ?
    Wenn ja, in welcher ?

    Gruß matjes :)
     
  9. Hi,

    die 3. Spalte enthält die Daten.

    Grüße
    falcon30
     
  10. Hallo falcon30 ,

    :| :| :|

    Was steht in A5 ?

    Ist dieser Begriff mit der Suchfunktion in Stückliste!A4:A224 zu finden ?
    Wenn ja, in welcher Zelle?

    Gruß matjes :)
     
Die Seite wird geladen...

Excel: SVERWEIS funktioniert nicht - Ähnliche Themen

Forum Datum
Excel 2013 SVERWEIS ergibt bei Tabellenübergreifender Nutzung 0 Microsoft Office Suite 16. Sep. 2015
Sverweis und #NV (Excel 2000) Microsoft Office Suite 11. Mai 2013
Sverweis Funktion in Excel 2003 Windows XP Forum 2. Dez. 2009
Excel WENN DANN SVERWEIS gibt falsche Werte Zurück? Microsoft Office Suite 15. März 2008
Excel 2003 - Formel SVerweis Microsoft Office Suite 9. Sep. 2005