Exel Tabellen mit Datensätzen

Dieses Thema Exel Tabellen mit Datensätzen im Forum "Microsoft Office Suite" wurde erstellt von Foradil1, 15. Nov. 2005.

Thema: Exel Tabellen mit Datensätzen Moin, mein Problem ist folgendes: Tabelle1 Artikelnummer   Beschreibung  Preis Tabelle2 Lfd.nr  Beschreibung   ...

  1. Moin, mein Problem ist folgendes:

    Tabelle1

    Artikelnummer   Beschreibung  Preis

    Tabelle2
    Lfd.nr  Beschreibung    Preis
    1         Artikel1             10?
    2         Artikel2             20?
    3         Artikel3             30?

    usw...

    nun möchte ich in Tabelle 1 so eine Art Rechnung erstellen, das heißt, wenn ich in Spalte Artikelnummer die 1 eingebe, daß die Beschreibung und der Preis automatisch ergänzt werden. Bei wenigen Artikeln funktioniert das ja mit der =Wenn(A1=1;Artikel1;) - Funktion, aber wenn ich sehr viele Artikel in der Tabelle 2 hinzufüge...

    geht sowas in Exel überhaupt oder brauch ich dafür ein Makro?

    schon mal vielen Dank für die Antwort!
     
  2. ich würd dir vorschlagen das ganze via makro zu lösen.

    weil dann kannst du einfach die Tabelle 2 beliebig ergänzen ... :)

    frage ist nur: ob du so ein makro programmieren kannst oder nicht ^^. Also nicht dass du das nicht könntest, aber mehr dass du weisst wie VBA proggn :)
     
  3. naja, vba hab ich mal probiert, aber ganz schnell wieder aufgegeben... dachte, da gibts vielleicht ne möglichkeit, das via exel-funktion zu lösen!?

    ansonsten bliebe mir nur der makro-rekorder, aber da wüßte ich auch nicht, wie ich das an meine bedürfnisse anpassen könnte...
     
  4. ist es immer die Zelle A1 das geändert wird?
     
  5. nicht wirklich!

    hab nur A1 als beispiel angegeben.

    im konkreten Fall ist es die Zeile B15 in der Tabelle 1. Die Daten sollen aus der Tabelle 2 gelesen werden. Hier ein komplettes beispiel:

    TABELLE1:
    -------------
    B15 C15 D15


    in Tabelle 2 befindet sich folgendes:
    TABELLE2:
    -------------
    B4 C4 D4
    1 Artikel1 20?
    B5 C5 D5
    2 Artikel2 30?
    usw.

    Wenn ich nun in TABELLE1 bei B15 die 1 eingebe, dann möchte ich, daß C15 mit dem Wert von C4 und D15 mit dem Wert von D4 ergänzt wird. natürlich möchte ich in Tabelle 1 weitere einträge vornehmen können, die ebenfalls automatisch ergänzt werden sollen. (bei B16 z.B. die 2, bei B17 z.B. die 107... je nachdem, welche Artikelnummer ich aus der Tabelle2 auswähle, ... )

    hoffe, ich hab euch jetzt nicht ganz verwirrt... ;)
     
  6. Hallo Foradil1,

    schau dir mal die Beschreibung von SVERWEIS an. Damit müßte es gehen.

    Gruß Matjes :)
     
  7. jo, danke! habe mal 10 seiten weiter hinten geschaut, und mit sverweis was brauchbares gefunden!

    habe nun noch ein anderes problem:

    A1 hat den Wert Max
    B1 hat den Wert Mustermann
    nun möchte ich in D1 den Text schreiben Hallo Max Mustermann. Wie funktioniert das?
    Mit =Hallo+A1+B1 geht das nicht...

    oder anderes beispiel:

    A1 hat den Wert 35?

    in D1 möchte ich dann schreiben Bitte überweisen Sie den Betrag von A1 ? .... allerdings ersetzt exel A1 nicht durch den Wert 35?.

    habt ihr da ne lösung parat?

    schon mal danke im vorraus!
     
  8. Versuch es mal mit
    Code:
    =Hallo& &A1& &B1
    oder
    Code:
    =Hallo &A1& &B1
    Code:
    =Bitte überweisen Sie den Betrag von &A1& ?
     
  9. ok....
    so weit funktioniert das in der theorie... um das ganze etwas komplexer zu machen, hier noch folgendes:

    ich habe die Tabelle Rechnung und die Tabelle Kunden.
    in der Tabelle Rechnung habe ich bei G16 die Kundennummer eingegeben.

    B12 in der Tabelle Rechnung enthält folgende Formel:

    =SVERWEIS(G16;Kunden!B5:I2000;4;WAHR)

    das Ergebnis aus der 4. Zelle ist dann Max. Nun möchte ich aber, daß nicht nur der 4. sondern auch der 5. Wert ausgelesen wird, so daß in B12 als Ergebnis Max Mustermann steht.

    Wenn ich dann folgendes schreibe

    =SVERWEIS(G16;Kunden!B5:I2000;4&5;WAHR)
    kommt nur ne fehlermeldung mit #Bezug

    nun könnte ich im höchstfall 2 spalten benutzen, die erste für den Vornamen (B12) mit
    =SVERWEIS(G16;Kunden!B5:I2000;4;WAHR)  (ergebnis wäre Max)
    und die zweite (C12) mit
    =SVERWEIS(G16;Kunden!B5:I2000;5;WAHR)  (ergebnis wäre Mustermann)

    allerdings wäre das eher eine unelegante lösung, da es sich durch die unterschiedlichen Namenlängen schlecht formatieren läßt.
     
  10. probier's mal mit
    Code:
    =SVERWEIS(G16;Kunden!B5:I2000;4;WAHR)& &SVERWEIS(G16;Kunden!B5:I2000;5;WAHR)
    Gruß Matjes :)
     
Die Seite wird geladen...

Exel Tabellen mit Datensätzen - Ähnliche Themen

Forum Datum
mehr Tabellen in Exel Windows XP Forum 26. Feb. 2005
EXEL Tabellen nicht direkt öffnen ! Windows XP Forum 15. Okt. 2004
Exel 2003: 2 Spalten vergleichen Microsoft Office Suite 8. Feb. 2014
Überschriftzeile in EXEL 2007 Microsoft Office Suite 12. Dez. 2012
EXEL-Tabelle in WORD-Tabelle umwandeln Windows XP Forum 29. Nov. 2012