Kernel panic: Attempted to kill init!

Dieses Thema Kernel panic: Attempted to kill init! im Forum "Linux & Andere" wurde erstellt von jabbah, 6. Jan. 2006.

Thema: Kernel panic: Attempted to kill init! Hallo ich bin absoluter Linux- Anfäger. Auf meinem Rechner hab ich Debian 3.1 installiert und soll als sicherung...

  1. Hallo

    ich bin absoluter Linux- Anfäger.
    Auf meinem Rechner hab ich Debian 3.1 installiert und soll als sicherung eine Partition ROOT_COPY anlegen, die ich notfalls starten kann, falls bei einem Update mal was schief geht und ich / nicht mehr booten kann. Ich hoffe das war soweit verständlich.

    meine Partitionen sind folgendermaßen gemountet:

    [sup] /dev/sda1                  /windows
      /dev/sda5                  /extra
      /dev/sda6                  /LOCAL_COPY
      /dev/sda7                  /ROOT_COPY
      /dev/sda8                  /export
      /dev/sda9                  swap
      /dev/sda10                /[/sup]

    mit einem ROOT_COPY skript wurden alle nötigen Dateien auf /ROOT_COPY kopiert.
    Danach habe ich die Config- Datei von GRUB angepasst (aber ich glaub da ist auch der Fehler, denn ich weiß nicht ob alles so stimmt)
    [sub]
    # menu.lst - See: grub(8), info grub, update-grub(8)
    #            grub-install(8), grub-floppy(8),
    #            grub-md5-crypt, /usr/share/doc/grub
    #            and /usr/share/doc/grub-doc/.

    ## default num
    # Set the default entry to the entry number NUM. Numbering starts from 0, and
    # the entry number 0 is the default if the command is not used.
    #
    # You can specify->saved' instead of a number. In this case, the default entry
    # is the entry saved with the command->savedefault'.
    default         0

    ## timeout sec
    # Set a timeout, in SEC seconds, before automatically booting the default entry
    # (normally the first entry defined).
    timeout         5

    # Pretty colours
    color cyan/blue white/blue

    ## password ['--md5'] passwd
    # If used in the first section of a menu file, disable all interactive editing
    # control (menu entry editor and command-line)  and entries protected by the
    # command->lock'
    # e.g. password topsecret
    #      password --md5 $1$gLhU0/$aW78kHK1QfV3P2b2znUoe/
    # password topsecret

    #
    # examples
    #
    # title         Windows 95/98/NT/2000
    # root          (hd0,0)
    # makeactive
    # chainloader   +1
    #
    # title         Linux
    # root          (hd0,1)
    # kernel        /vmlinuz root=/dev/hda2 ro
    #

    #
    # Put static boot stanzas before and/or after AUTOMAGIC KERNEL LIST

    ### BEGIN AUTOMAGIC KERNELS LIST
    ## lines between the AUTOMAGIC KERNELS LIST markers will be modified
    ## by the debian update-grub script except for the default options below

    ## DO NOT UNCOMMENT THEM, Just edit them to your needs

    ## ## Start Default Options ##
    ## default kernel options
    ## default kernel options for automagic boot options
    ## If you want special options for specifiv kernels use kopt_x_y_z
    ## where x.y.z is kernel version. Minor versions can be omitted.
    ## e.g. kopt=root=/dev/hda1 ro
    # kopt=root=/dev/sda10 ro

    ## default grub root device
    ## e.g. groot=(hd0,0)
    # groot=(hd0,9)

    ## should update-grub create alternative automagic boot options
    ## e.g. alternative=true
    ##      alternative=false
    # alternative=true

    ## should update-grub lock alternative automagic boot options
    ## e.g. lockalternative=true
    ##      lockalternative=false
    # lockalternative=false

    ## altoption boot targets option
    ## multiple altoptions lines are allowed
    ## e.g. altoptions=(extra menu suffix) extra boot options
    ##      altoptions=(recovery mode) single
    # altoptions=(recovery mode) single

    ## controls how many kernels should be put into the menu.lst
    ## only counts the first occurence of a kernel, not the
    ## alternative kernel options
    ## e.g. howmany=all
    ##      howmany=7
    # howmany=all

    ## should update-grub create memtest86 boot option
    ## e.g. memtest86=true
    ##      memtest86=false
    # memtest86=true

    ## ## End Default Options ##

    title           Debian GNU/Linux, kernel 2.6.8-2-686
    root            (hd0,9)
    kernel          /boot/vmlinuz-2.6.8-2-686 root=/dev/sda10 ro
    initrd          /boot/initrd.img-2.6.8-2-686
    savedefault
    boot

    title           Debian GNU/Linux, kernel 2.6.8-2-686 (recovery mode)
    root            (hd0,9)
    kernel          /boot/vmlinuz-2.6.8-2-686 root=/dev/sda10 ro single
    initrd          /boot/initrd.img-2.6.8-2-686
    savedefault
    boot

    title           Debian GNU/Linux, kernel 2.6.8-2-686 (ROOT_COPY)
    root            (hd0,6)
    kernel          (hd0,6)/boot/vmlinuz-2.6.8-2-686 root=/dev/sda7 ro
    initrd          /boot/initrd.img-2.6.8-2-686
    savedefault
    boot
    ### END DEBIAN AUTOMAGIC KERNELS LIST
    [/sub]

    ich bekomm dann zwar beim booten dieses Fenster und kann auch meine ROOT_COPY auswählen, aber wenn er es dann laden will bekomm ich diese Fehlermeldung:
    [sub]
    Kernel panic: Attempted to kill init!
    [/sub]
    und dann bleibt der Rechner stehen und nichts passiert mehr.


    Kann mir jemand dabei helfen??
     
  2. Hi,

    deine menu.lst scheint auf den ersten Blick zu passen.
    Ich schätze mal du musst die /etc/fstab auf deiner ROOT_COPY anpassen ...

    Gruß
    Sven
     
  3. und wie passe ich die an?

    im Moment sieht sie so aus:

    [sub]# /etc/fstab: static file system information.
    #
    # <file system> <mount point>   <type>  <options>       <dump>  <pass>
    proc                    /proc                   proc     defaults             0       0
    /dev/sda10         /                          ext3    defaults,errors=remount-ro 0       1
    /dev/sda6           /LOCAL_COPY     ext3    defaults            0       2
    /dev/sda7           /ROOT_COPY      ext3     defaults            0       2
    /dev/sda8           /export               ext3     defaults            0       2
    /dev/sda5           /extra                 ext3     defaults            0       2
    /dev/sda1           /windows           vfat      defaults            0       2
    /dev/sda9           none                  swap    sw                    0       0
    /dev/hda            /media/cdrom0   iso9660 ro,user,noauto  0       0
    [/sub]

    ich müsste dann aber auch nur die fstab von /ROOT_COPY anpassen, oder?
     
  4. ändern in:

    Code:
    proc                    /proc                   proc     defaults             0       0
    /dev/sda7         /                          ext3    defaults,errors=remount-ro 0       1
    /dev/sda6           /LOCAL_COPY     ext3    defaults            0       2
    /dev/sda8           /export               ext3     defaults            0       2
    /dev/sda5           /extra                 ext3     defaults            0       2
    /dev/sda1           /windows           vfat      defaults            0       2
    /dev/sda9           none                  swap    sw                    0       0
    /dev/hda            /media/cdrom0   iso9660 ro,user,noauto  0       0
    korrekt

    Gruß
    Sven
     
  5. wunderbar, das war die Lösung des Problems.
     
  6. i know :p
     
Die Seite wird geladen...

Kernel panic: Attempted to kill init! - Ähnliche Themen

Forum Datum
Kernel Panic Linux & Andere 2. Juni 2005
Kernel panic: VFS: Unable to mount ... Linux & Andere 1. Okt. 2004
sp4 + kernel panic Windows 95-2000 2. Juli 2003
PC hängt sich auf /Kernel-Power Ereigniss-ID 41 Windows 10 Forum 5. Okt. 2015
STOP: 0x00000077 KERNEL_STACK_INPAGE_ERROR Windows XP Forum 13. März 2015