SVerweis weigert sich hartnäckig

Dieses Thema SVerweis weigert sich hartnäckig im Forum "StarOffice, OpenOffice und LibreOffice" wurde erstellt von soulsurfer42, 21. Mai 2010.

Thema: SVerweis weigert sich hartnäckig Hallo Forum, ich habe ein drängendes Problem und hoffe, dass mir jemand helfen kann. Ich habe zwei Calc-Dateien,...

  1. Hallo Forum,

    ich habe ein drängendes Problem und hoffe, dass mir jemand helfen kann. Ich habe zwei Calc-Dateien, wobei eine die andere referenzieren soll. Das ganze soll über SVERWEIS funktionieren. Das merkwürdige ist, dass es bislang immer geklappt hat - bis ich die Datei, in der der SVERWEIS enthalten ist, umbenannt habe. Klar, hätte ich die referenzierte Datei umbenannt, hätte SVERWEIS nichts finden können. So kommt mir das Verhalten aber extrem unlogisch vor - zumal auch das Rück-Umbenennen keine Hilfe brachte.

    Zur Erläuterung: es gibt eine Datei Aktenregister, in der alle Akten unter Angabe von Aktenzeichen, Rubrum, Stundensatz etc. enthalten sind. Die zweite Datei - die die SVERWEISe enthält - dient der Erfassung von Arbeitszeiten, die den Akten zugeordnet werden. Das Aktenregister ist eine einfache Tabelle folgenden Inhalts:

    Aktenzeichen Akte Referat Stundensatz Pauschale Streitwert Abgerechnet Honorar netto Fremdgeld Auslagen
    0815/10 X./.Y Wettbewerbsrecht 5,00 € 0,00 € 30.000,00 € 0 0 0 0


    In der Zeiterfassung soll nun allein das Aktenzeichen, die geleistete Tätigkeit und der Zeitaufwand eingetragen werden. Das Rubrum (steht oben unter Akte) soll er sich ziehen; außerdem soll er das Feld Stundensatz auslesen, um daraus die Vergütung zu berechnen.

    Für das Rubrum habe ich folgenden SVERWEIS:

    =SVERWEIS(B2;'file:///T:/Kanzleiverwaltung/Zeiterfassung/Aktenregister.ods'#$Aktenregister.$A$2:$D$10000;2;FALSCH())

    Für das Auslesen des Stundensatzes gilt folgender:

    =SVERWEIS(B2;'file:///T:/Kanzleiverwaltung/Zeiterfassung/Aktenregister.ods'#$Aktenregister.$A$2:$D$10000;4;FALSCH())

    Das sieht für mich doch eigentlich total richtig aus - trotzdem meckert Calc mit der Angabe #REF! .

    Wenn mir jemand helfen kann - ich werde hier wahnsinnig.

    Besten Dank schon Mal,

    Christian
     
  2. Problem gelöst - der Tabellenbereich hatte nicht den Namen Aktenregister. Ich habe jetzt in den Verweisen Tabelle1 aufgenommen und alles läuft wie am Schnürchen.

    Bis demnächst mal!

    Christian
     
Die Seite wird geladen...

SVerweis weigert sich hartnäckig - Ähnliche Themen

Forum Datum
Excel 2013 SVERWEIS ergibt bei Tabellenübergreifender Nutzung 0 Microsoft Office Suite 16. Sep. 2015
Sverweis und #NV (Excel 2000) Microsoft Office Suite 11. Mai 2013
Sverweis Funktion in Excel 2003 Windows XP Forum 2. Dez. 2009
Excel WENN DANN SVERWEIS gibt falsche Werte Zurück? Microsoft Office Suite 15. März 2008
WENN mit Sverweis verknüpfen gibt keine Zahl zurück StarOffice, OpenOffice und LibreOffice 14. März 2008