SVERWEIS zu mehreren Excel-Blättern

Dieses Thema SVERWEIS zu mehreren Excel-Blättern im Forum "Microsoft Office Suite" wurde erstellt von phil., 26. Apr. 2005.

Thema: SVERWEIS zu mehreren Excel-Blättern Kann mir jemand helfen: Ich habe insgesamt 4 Excel-Blätter in der gleichen Datei. 3 davon sind Adressfiles mit je...

  1. Kann mir jemand helfen:
    Ich habe insgesamt 4 Excel-Blätter in der gleichen Datei. 3 davon sind Adressfiles mit je 40'000 Adressen. Das vierte ist ein Auswertungs-Blatt. In diesem muss ich einen SVERWEIS auf die anderen 3 Adressfiles machen (d.h. der SVERWEIS muss alle 3 Adressfiles nach dem Suchkriterium durchsuchen).
    Vielen Dank für die Hilfe
     
  2. Habe das gleiche Problem. hast Du schon eine Lösung gefunden?
     
  3. Hi,

    das wird ´ne Formel, wie ich sie liebe, aber wenn sie einigermaßen verständlich sein soll, brauche ich folgende Angaben:

    1) In welcher Zelle steht der Suchbegriff (sowohl im Auswertungs- als auch in den Adressblättern?
    2) Welche Zellen aus den 3 Adressblättern sollen durch den SVerweis angezeigt werden?
    3) Ist der Suchbegriff eindeutig (z.B. Kundennr.) oder mehrdeutig (z.B. Name=Müller)?

    Gruß
    PiPi
     
  4. Habe mittlerweile das Problem gelöst. Aber die Vorgaben waren wie folgt:

    1) Suchbegriff steht im Auswertung- als auch in den Adressblättern
    2) Der ganze Adress-Stamm soll angezeigt werden
    3) Der Suchbegriff ist eindeutig
    4) Ich habe mir eine Kontrollnummer gebastelt, mit welcher der SVERWEIS auf nur jeweils auf 1 Adressblatt zugreifen muss

    Habe das ganze mit WENN und SVERWEIS gelöst:
    =WENN(A2=Kontrollnummer1;SVERWEIS(B2;'Adressen XXX'!$1:$65536;gesuchter Wert in Spalte?;0);WENN(A2=Kontrollnummer2;SVERWEIS(B2;'Adressen YYY'!$1:$65536;gesuchter Wert in Spalte?;0);SVERWEIS(B2;'Adressen ZZZ'!$1:$65536;gesuchter Wert in Spalte?;0)))

    Hättest du auch eine Lösung, wenn der Punkt 4) nicht vorhanden ist, d.h. wenn der SVERWEIS alle 3 Adressblätter durchsuchen muss?

    Vielen Dank
    Gruss Phil
     
  5. Hab ich:

    =WENN(NICHT(ISTNV(SVERWEIS(A1;'Adressen XXX'!$A$1:$B$3;2;0)));SVERWEIS(A1;'Adressen XXX'!$A$1:$B$3;2;0);WENN(NICHT(ISTNV(SVERWEIS(A1;'Adressen YYY'!$A$1:$B$3;2;0)));SVERWEIS(A1;'Adressen YYY'!$A$1:$B$3;2;0);WENN(NICHT(ISTNV(SVERWEIS(A1;'Adressen ZZZ'!$A$1:$B$3;2;0)));SVERWEIS(A1;'Adressen ZZZ'!$A$1:$B$3;2;0);Nicht gefunden)))

    Hierbei gehe ich davon aus, dass der Suchbegriff in allen 4 Tabellen in Spalte A steht, und sich die auszugebenden Daten in einer der 3 Adress-Tabellen Spalte B befinden.

    Gruß
    PiPi
     
  6. Coole Sache  :D

    Danke und Gruss
    Phil
     
Die Seite wird geladen...

SVERWEIS zu mehreren Excel-Blättern - Ähnliche Themen

Forum Datum
Excel 2013 SVERWEIS ergibt bei Tabellenübergreifender Nutzung 0 Microsoft Office Suite 16. Sep. 2015
Sverweis und #NV (Excel 2000) Microsoft Office Suite 11. Mai 2013
SVerweis weigert sich hartnäckig StarOffice, OpenOffice und LibreOffice 21. Mai 2010
Sverweis Funktion in Excel 2003 Windows XP Forum 2. Dez. 2009
Excel WENN DANN SVERWEIS gibt falsche Werte Zurück? Microsoft Office Suite 15. März 2008