Zielpfad ist zu lang

  • #1
J

Jominator

Mitglied
Themenersteller
Dabei seit
28.01.2021
Beiträge
15
Reaktionspunkte
0
Hallo allerseits,

beim Kopieren von einer NTFS/GPT formatieriten NVME auf eine interne NTFS/GPT formatierite SATA-SSD wurde folgender Fehler angezeigt "Zielpfad ist zu lang, bla bla bla..."

Wie kann das denn sein? Der Zielpfad lag sogar direkt im Rootverzeichnis, wohingegen sich die Quelle bereits in mehreren Unterordnern mit insgesamt 20 Zeichen befand.

Hat dafür jemad eine Erklärung?
 
  • #3
Danke für den Link. Aber anscheinend kennt Microsoft seine eigenen Beschränkungen nicht gut. Wenn man die Limitierungen ausprobiert, wird man, zumindest bei meiner W10 22H2 19045.3324 Version feststellen, dass der maximale Pfad nur 248 Zeichen lang sein darf.


Und das kuriose ist, wenn man innerhalb des letzten Pfads eine neue Textdatei anlegt, heißt die ja per default "Neues Textdokument". Man kann diesen Namen aber nicht mehr ändern, auch nicht in einen mit weniger Zeichen. Na ja, Windows halt.


Eine Erklärung für das Verhalten in meinem speziellen Fall, bietet die verlinkte Seite aber nicht. Die Option, die Beschränkung zu beenden werde ich das nächste Mal, wenn ich mir dem Problem konfrontiert werde, aber mal ausprobieren.
 
  • #4
Die 255 Grenze stammt noch aus DOS Zeiten, leider hat MS das in Windows nie geändert bzw. angepasst, auch in W11 nicht. Man kann aber via Reg Eintrag den Wert auf unbegrenzt stellen:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\FileSystem

Hier nun muss Du ein neuer DWORD (32-bit) Wert mit dem Namen „LongPathsEnabled“ anlegen und diesem DWORD den Wert „1“ zuweisen, dann wars das mit der 255 zeichen Grenze ...
 
  • #5
hp schrieb:
... dann wars das mit der 255 zeichen Grenze ...
Bei mir, auch nach einem Neustart, ist es das nicht! Zumindest nicht mit dem Systemeigenen Datei-Explorer.
Einige Informationen deuten darauf hin, dass es mir diesem Patch lediglich einigen Drittanbietern möglich ist.
Oh je.

2023-09-04_121540.jpg
 
Zuletzt bearbeitet:
  • #6
Korrekterweise sollte man bei solchen Hinweisen folgendes hinzu schreiben:

Man schaltest damit nicht die maximale Pfadlänge aus. Man sorgt lediglich dafür, dass Anwendungen, bei denen der Entwickler im Anwendungsmanifest deklariert hat, dass diese mit langen Pfaden klarkommen, diese auch nutzen können!

Die entsprechenden Anwendungen müssen dies also zuerst einmal unterstützen. Der Windows Explorer unterstützt es bisher nicht. Auch nicht mit dieser Einstellung.
 
  • #7
Richtig, hätte ich machen sollen ... (-;
 
  • #8
WIN+R + gpedit.msc => ausführen

1698774681266.png
 
Thema:

Zielpfad ist zu lang

ANGEBOTE & SPONSOREN

Statistik des Forums

Themen
113.867
Beiträge
708.102
Mitglieder
51.511
Neuestes Mitglied
Lukers92
Oben