DFS : Replizierung super-langsam trotz schnellem Netz + zuviel Last auf DC

Dieses Thema DFS : Replizierung super-langsam trotz schnellem Netz + zuviel Last auf DC im Forum "Windows Server-Systeme" wurde erstellt von duncan.blues, 16. Feb. 2008.

Thema: DFS : Replizierung super-langsam trotz schnellem Netz + zuviel Last auf DC Hallo! Ich habe kürzlich in einem kleinen Netz wo bislang ein Win 2003 SBS Alleinherrscher war einen zweiten Server...

  1. Hallo!

    Ich habe kürzlich in einem kleinen Netz wo bislang ein Win 2003 SBS Alleinherrscher war einen zweiten Server mit Windows 2003 Standard als Mitgliedsserver installiert, der jetzt vor allem als Fileserver fungieren soll.
    Das Hinzufügen zur Domäne war kein Problem, als zweiten Schritt habe ich ihn schonmal zum Secondary DNS ernannt, auch kein Problem.
    Da der alte Server nach wie vor der Herrscher über das Backup-Drive ist, dachte ich mir es wäre eine klasse Idee, einfach zwischen beiden ein DFS aufzusetzen. Das DFS an sich war auch kein großes Thema, nur mit der Replizierung hapert's. Im Prinzip funktioniert die Replikation und wenn man nur eine einzelne kleine Datei im DFS anlegt, dann wandert die auch nach 1-2 Sekunden auf den jeweils anderen Rechner.
    Wenn ich jedoch im Block sagen wir mal ein Verzeichnis mit einigen hundert MB ins DFS schiebe, dann ist Schluss mit Lustig. Der Hauptserver ist dann bis auf weiteres fast nicht mehr zu bedienen, alle Programme, Explorer und selbst das Aufklappen des Start Menüs vergehen im Zeitlupenthempo. Der Server ist ein Dualcore Dualprozessor Xeon mit 4 GB RAM, er ist also eigentlich alles andere als unterdimensioniert für ein kleines Netz. Zur Zeit während ich hier schreibe und diese Merkwürdigkeiten beobachte ist zudem außer mir keiner am Server oder irgendwo sonst im Netz angemeldet. Im Taskmanager geht die Last der vier Prozessoren auch nicht über 30% und in der Prozessliste ist nichts auffälliges.
    Ferner ist auf der Netzwerkleitung quasi nichts los. Die beiden Server sind mit Gigabit verbunden, die Auslastung erreicht beim Replizieren aber nichtmal 1%.
    Wenn ich mit dem Explorer einfach die gleiche Menge Daten vom einen Server in ein normales Share des anderen schiebe, dann läuft der Kopiervorgang jedoch genau so schnell und problemlos ab, wie man's erwarten würde.
    Im Ereignislog von beiden Maschinen findet sich nichts was auf einen Fehler schliessen liesse. DNS sollte korrekt konfiguriert sein. Auf beiden Maschinen kann man den jeweils anderen problemlos auflösen.

    Man könnte jetzt sagen, ok, ein paar hundert MB sind vielleicht etwas viel auf einmal für die Replikation, aber ich muss es irgendwie hinkriegen, runde 170 GB Gesamtmenge an einem Wochenende (oder notfalls verteilt auf zwei) in die neue Fileserverstruktur zu kriegen. Ich hatte eigentlich nicht erwartet, dass das mit Gigabit irgendwo ein Problem darstellen könnte. Zudem ist die Replikationsgeschwindigkeit schon bei mageren 60 MB im Block extremst dürftig. Manchmal dauert es geschlagene zwei Minuten oder drei bis die Datenmenge auf dem Zielrechner um weitere 2 MB angestiegen ist.

    Bin inzwischen ziemlich ratlos.
     
  2. Ich tippe jetzt mal auf das typische AutoNegotiation-Problem bei Gigabit-Karten - wenn du die Möglichkeit hast, stell mal die Übertragungsgeschwindigkeit an beiden NICs sowie am Switch fix auf 1000MB Full-Duplex, das sollte dein Problem lösen.
     
  3. Neg. Dann würde die Geschwindigkeit ja auch bei direktem Kopieren in ein entferntes Share so langsam laufen.
    Ich habe beim Kopieren von einem großen Satz Dateien jetzt eine effektive Geschwindigkeit von mindestens 300 MBit/sec gemessen. Beim Replizieren beträgt der Traffic im Idealfall etwa 10 Mbit, im Durchschnitt aber eher magere 2 Mbit, zwischendurch sogar mit längeren Pause ganz ohne Traffic.

    Ich habe in der Zwischenzeit mal die Größe des Stagingverzeichnisses auf beiden Maschinen vom Default (war glaube ich 660 MB) auf 2.5 GB vergrößert und den Replikationsdienst auf eine feste Portnummer konfiguriert. Dann habe ich noch dafür gesorgt, dass diese Portnummer am Switch gegenüber anderem Traffic keinesfalls niedriger priorisiert wird. Da zum Zeitpunkt meiner Tests aber ausser dem Replikationstraffic nichts anderes im Netz unterwegs war, kann's daran nicht gelegen haben.

    Ich bin mir relativ sicher, dass es kein grundlegendes TCP/IP Problem ist. DNS ist wie erwähnt auch vermutlich in Ordnung. Zur Sicherheit habe ich beide Maschinen sogar in der hosts Datei des jeweils anderen eingetragen, sodass sie einander sogar ohne DNS Abfrage finden müssten.

    Jedenfalls: Problem weiter ungelöst. :|


    PS: Das Problem mit der hohen Last liess sich weitestgehend eingrenzen. Nachdem ich das Staging-Verzeichnis von der Echtzeit Virenprüfung ausgenommen habe, ging die Last runter. Leider ist das Problem mit der langsamen Replizierung damit nicht verschwunden.
    Ich habe außerdem das Problem, dass die Replizierung oftmals gar nicht erst anläuft und mit einer Warnung, Ereignis 13508, hängen bleibt. Meistens bequemt sich das System dann irgendwann doch, mit der Replizierung anzufangen. Mehrfach ist jedoch das Anlegen einer neuen DFS Replizierung erstmal mit unerklärlichen Fehlern fehlgeschlagen. Nachdem ich die betroffene Replizierung dann aus der DFS Verwaltung gelösch habe, auf beiden Seiten NTFRS gestoppt habe, auf dem DC zuerst wieder gestartet habe und nachdem der bereit war, den NTFRS auf dem Fileserver gestartet habe und schliesslich die Replizierung exakt genauso wie zuvor nochmal angelegt habe - da klappte es dann irgendwie.
    In der Registry beider Maschinen häufen sich inzwischen die Tombstoned Replica Sets. Alles sehr unzufriedenstellend. Ich weiss gar nicht wie oft ich dieses Wochenende schon den vermaledeiten NTFRS neu gestartet habe.

    :|
     
Die Seite wird geladen...

DFS : Replizierung super-langsam trotz schnellem Netz + zuviel Last auf DC - Ähnliche Themen

Forum Datum
Replizierung schlägt fehl ID1311 Windows XP Forum 12. Feb. 2008