Probleme mit Mischstruktur W2k/W2k3

Dieses Thema Probleme mit Mischstruktur W2k/W2k3 im Forum "Windows Server-Systeme" wurde erstellt von Joshua, 14. März 2005.

Thema: Probleme mit Mischstruktur W2k/W2k3 Moin Gemeinde ! Folgende Situation: Zwei Standorte, an Standort A ein W2k3-DC im W2k-pur Modus, an Standort B am...

  1. Moin Gemeinde !

    Folgende Situation:
    Zwei Standorte, an Standort A ein W2k3-DC im W2k-pur Modus, an Standort B am Wochenende einen W2k-DC zur Domäne hinzugefügt. Soweit, so gut.

    Der DC an Standort B war VORHER der einzige DC einer anderen Domäne, also habe ich ihn heruntergestuft, DNS, DHCP und WINS deinstalliert und ihn dann wieder hochgestuft. Klappte eigentlich auch alles - dachte ich...

    Standorte habe ich definiert, meinen DC an Standort B in der MMC auch in den entsprechenden Standort verschoben, Subnetz definiert etc.
    Heute morgen das böse Erwachen: DNS funktioniert nicht richtig, die Replikation klappt nicht, Eventlog voller Fehler.

    Ok, also alles wieder retour (die Clients haben jetzt den DC an Standort A als prim. DNS eingetragen, soweit ist alles im Trocknen), wieder dcpromo, nun ist die Kiste ein Member der Domäne. DNS und WINS sind deinstalliert, die Standorteinträge sind gelöscht und im DNS an Standort A habe ich die Verweise auf den ehem. DC alle gelöscht.

    Wenn ich nun ein nslookup mache, taucht aber die IP-Adresse des ehem. DC an Standort B nach wie vor als Internet Adress für diese Domain auf - und ich frage mich warum ?!?

    Mein Ziel ist es nun, das AD soweit zu bereinigen, das vom ehem. DC an Standort B nix mehr über ist und ich ihn nochmals mittels dcpromo hochstufen kann; in der Hoffnung, das diesmal dann alles klappt.

    Eigentlicherweise hätte es die ganzen Probleme gar nicht geben dürfen - aber gut, man wird ja desöfteren eines besseren belehrt. Kann jemand anhand der Beschreibung nachvollziehen, was da gelaufen ist ?!?
    Ich hätte, wenn es gar nicht mehr anders geht, die Möglichkeit, den Server an Standort B komplett neu zu installieren, möchte das aber eigentlich vermeiden.

    Ich kämpfe jetzt seit heute morgen halb neun damit, wenn ich irgendwelche Infos vergessen haben sollte, reiche ich diese auf Anfrage selbstverständlich nach.
    Bin für den Schubs in die richtige Richtung dankbar ;D

    Cheers,
    Joshua


    P.S.:
    Die beiden Standorte sind btw via IPSEC vernetzt, völlig transparent - geblockte Ports/Protokolle scheiden also als Fehlerquelle aus.
     
  2. nslookup: lokaler cache... freimachen.

    ipconfig /flushdns
     
  3. @paule:
    Das ist selbstverständlich schon mehrfach gemacht worden - leider ergebnislos.

    Cheers,
    Joshua
     
  4. Ok, mittlerweile habe ich mit ntdsutil mal nachgeschaut: Lt. Metadata gibt es nur noch einen DC, einen Standort etc. - die Metadaten sehen also brauchbar aus, das gibts kein Kuddelmuddel. Auch die FSMO werden alle vom DC am Standort A ausgeführt und sind verfügbar.

    Nach wie vor taucht aber der ehem. DC von Standort B mit seiner IP-Adresse als zust. Domain-Controller beim nslookup auf, warum auch immer und wo auch immer dieser Eintrag her kommen mag: in den DNS-Zonen auf DC A ist er lediglich noch als HOST (A) eingetragen, mehr auch. Auch ein Löschen und Neu-Registrieren mit ipconfig /registerdns brachte keine Änderung.
    Evtl. hakt es an den Nachwehen des WINS-Lookup, der vorher aktiviert war ?!?

    However, ich tendiere aufgrund der sauberen Metadaten dazu, den Server an Standort B erneut zum DC zu promoten; als Vorbereitung habe ich DNS und WINS komplett de- und DHCP de- und neu-installiert sowie autorisiert. Der DHCP-Server läuft nun auch klaglos und verteilt brav IP-Adressen; die Clients machen derzeit DNS- und WINS-Lookup direkt mit dem DC an Standort A, was sich aber wieder ändern soll, wenn der Server an Standort B als DC rund läuft.

    Any more ideas ?!?

    Cheers,
    Joshua
     
  5. Tach Post,

    Das AD zuzumüllen wird dein Problem nicht lösen ;)
    Normalerweise mach' ich das immer so:

    - Übertrage sämltiche Rollen (wenn vorhanden) auf den funktionierenden DC.
    - Demote den einen DC und bereinige mit ntdsutil die Metadaten
    - Bereinige die (AD gespeicherten) DNS Zonen
    - Bereinige den IP Cache und leere die WINS Datenbank(en)
    - Promote den zweiten DC

    That's it ;)

    Gruß
    Sven
     
  6. S. mein Posting, die sind alle auf dem DC an Standort A.

    S. mein Posting, Server an Standort B ist zum Member zurückgestuft, lt. ntdsutil ist das AD sauber

    S. mein Posting, Zonen sind bereinigt.

    S. mein Posting, Cache gelöscht, WINS an Standort B ist de-installiert, WINS-Datenbank an Standort A wurde kompl. gelöscht; ipconfig /flushdns auf allen Server ausgeführt.

    Das wäre das nächste, was ich machen würde - mit dem Risiko, das es wieder schiefgeht....

    Ja, soweit war ich am Samstag schonmal.....

    Cheers,
    Joshua
     
  7. Hi Joshua,

    Das ist die Standardvorgehensweise, welche auch von Microsoft empfohlen wird. Ich mag' Dir ja nicht zu nahe treten, aber dann haste eventuell nen Fehler gemacht oder was übersehen.
    Wir machen das genau so bei den noch knapp 100 Windows 2000 DC's, bevor sie auf W2K3 upgegraded werden ;)

    Gruß
    SVen
     
  8. Ich hab mir schon das Hirn zermartert, ob und was ich übersehen haben könnte - ohne Ergebnis, ich bin genau wie von MS beschrieben vorgegangen.
    Das Einbinden bzw. Promoten des Servers an Standort B hat ja auch wunderbar geklappt, die Probleme sind erst bei/während/nach der ersten Replikation enstanden und ich wüsste nicht, was ich bei diesen DCs anders gemacht hätte als bei den anderen, die ich administriere.

    Ich werde also wohl nachher nochmal mein Glück versuchen - auch, wenn dann evtl. ne Nachtschicht fällig wird....
    Thx anyway.....

    Cheers,
    Joshua
     
  9. So, dcpromo auf Server B ausgeführt, lief erwartungsgemäss ohne Fehler durch. Die Replikation klappt -so ich den Logs Glauben schenk darf- nun auch. Beinah zu schön, um wahr zu, aber nur beinah:
    Auf dem DC an Standort B ist der DNS-Server installiert und ordnungsgemäss gestartet, bei der Replikation wurden die beiden Reverse-Lookupzonen auch von Standort A übertragen - die Forward-Lookupzone fehlt allerdings und ich suche entweder nach einer Erklärung oder nach einer Möglichkeit, diese doch noch übertragen/repliziert zu bekommen.
    Any ideas ?!?

    Cheers,
    Joshua
     
  10. Ok, nach dem ich Stunden mit der Fehlersuche bei eventid.net und den referenzierten MS-Seiten verbracht habe, hat sich das Problem allem Anschein nach gelöst: Das De- und Neu-Installieren des DNS-Servers unter erneuter Bereinigung ALLER DNS-relevanten Einträge -also auch die, auf die Netlogon zugreift- hat letztenendes die Lösung gebracht.

    Cheers,
    Joshua
     
Die Seite wird geladen...

Probleme mit Mischstruktur W2k/W2k3 - Ähnliche Themen

Forum Datum
SEHR DRINGEND: Probleme bei Upgrade auf Windows 7 Windows Vista Forum 13. Nov. 2016
W10M - Glance Screen & DTTWU Probleme Windows 10 Forum 4. Nov. 2016
probleme mit windows 7 update bitte um hilfe. Windows 7 Forum 4. Nov. 2016
Probleme mit .NET Framework 3.5 installation Windows 10 Forum 19. Okt. 2016
Windows 10 Bluetooth Probleme Windows 10 Forum 17. Okt. 2016