extrem hohe Netzwerklast durch BITS

Dieses Thema extrem hohe Netzwerklast durch BITS im Forum "Windows-Updates" wurde erstellt von mikebirth, 24. Apr. 2007.

Thema: extrem hohe Netzwerklast durch BITS Hallo WinTotal-Gemeinde, ich habe gleich zwei Fragen! Wir haben ein ungemanagedes (schreibt man das so?)...

  1. Hallo WinTotal-Gemeinde,
    ich habe gleich zwei Fragen!

    Wir haben ein ungemanagedes (schreibt man das so?) VLAN-Segment, in dem ca. 100 XP-Clients stehen. Kein AD, kein DC, kein Server. Nur Proxy und Bluecoat. Das Problem: Da auf allen Rechnern BITS und Windows Update eingeschaltet war, ging die gesamte Bandbreite, die für http (Port 80) zur Verfügung stand (mehr als 6MBit) für diesen Service drauf. Der Rest der http-Anfragen gerät heftig ins Stocken. Das passiert aber nicht einmalig und kurz, sondern ständig und gleichbleibend hoch.

    Nachdem wir nun manuell auf allen Clients Windows-Update deaktiviert haben (auch Java-Updates, proxycfg -u, nicht aber den BITS-Dienst), besteht das Problem immer noch. Die Last geht nicht runter.

    1. Frage: Was läuft da falsch?
    2. Frage: Kann ich in einem solchen ungeman. Netzwerk einen WSUS-Server betreiben oder bin ich dann auch gewzungen, AD und DC zu verwenden?

    Bin dankbar für jeden Tipp!
    mfg
    mikebirth
     
  2. Hi,
    erstmal danke für den ersten Tipp.
    Generell funktioniert das Verfahren so, wie es konfiguriert ist, d.h. die Updates kommen (sehr langsam) und keine der beteiligten Komponenten spuckt Fehlermeldungen aus, auch nicht die aus dem MS-Dokument, welches Du verlinkt hast. Das Problem behindert aber die Arbeitsabläufe bei uns, weil http Reaktionszeiten jenseits von Gut und Böse hat.

    Kleine Konkretisierung: Das VLAN-Segment selbst besteht schon mehr als ein Jahr, das Lastproblem trat aber erstmals in der Nacht vom 26. zum 27. Februar, ca. 3 Uhr früh, auf. Seitdem versuchen wir verschiedene Lösungen.
    Oben hat sich noch ein kleiner Fehler eingeschlichen: Statt Bluecoat muss es heißen: Finjan Firewall.
     
  3. Den Folgeartikel http://support.microsoft.com/kb/900935 hast Du sicher auch schon gelesen.
    Anyway, für mich steht bislang überhaupt nicht fest, dass es ein Problem mit Windows Update bzw. den zugehörigen Diensten ist. Um das zu errurieren, könnte man auf diversen Clients testweise den Dienst Automatische Updates deaktivieren. Zeigt das auf diesen Clients Besserung, ist es tatsächlich Windows Update.

    Falls nicht, würde ich mich an Deiner Stelle eher an das WindowsXP-Forum hier oder die Newsgroup microsoft.public.de.german.windowsxp.networking wenden. Insebesondere dann, wenn das vollständige Deaktivieren der Personal Firewall S*a*ftware auf den Clients und stattdessen das Aktivieren der Windows Firewall keine Abhilfe schafft.

    Bye,
    Freudi
     
  4. Hi Freudi,
    die Analyse der Pakete hat ergeben, es werden zu 90 % BITS Pakete übertragen. Auf der anderen Seite der Leitung stehen AKAMAI-Server. Eigentlich hat aber BITS nix zu tun, weil überall schon Windows-Update deaktiviert ist. Oder bin ich da auf dem Holzweg, was das Zusammenspiel zwischen diesen beiden Diensten betrifft?

    Das Dok 900935 hatte leider auch keine Hinweise, die wir nicht schon ausprobiert haben. Ich habe auch auf allen Kisten proxycfg -d laufen lassen.

    Das Deaktivieren von WindowsUpdate ist flächendeckend geschehen, eine positive Wirkung hat das aber nicht gezeigt. Dein Vorschlag, den Dienst nur testweise zu deaktivieren, läßt sich nicht korrekt umsetzen, weil wir den Erfolg am Client nicht überprüfen können. Wir haben kein Tool gefunden, dass zuordnen könnte, welcher Client welche BITS-Pakete angefordert hat. Kennst Du ein solches Tool???

    mfg
    mikebirth
     
  5. BITS wird nicht nur von Windows/Auto Update genutzt. Womöglich sind es auch z.B. AutoUpdate-Mechanismen der installierten Software. Was genau wurde denn unmittelbar vor dem Auftreten des Problems installiert, deinstalliert, aktualisiert und/oder neu konfiguriert? Schreib bitte nicht nichts ;)

    Huh? Dann deaktviert es halt auf allen Clients (vorübergehend) , z.B. via net stop ......
    Ansonsten verweise ich auf mein Vorposting bzgl Personal Firewall S*a*ftware.

    Bye,
    Freudi
     
  6. jo, also: die bestehenden ca. 98 clients wurden natürlich nicht angefasst, weil es dazu keine notwendigkeit gab. am tag zuvor haben wir zwei neue, exakt gleich konfigurierte XP-clients ins netz gestellt. daran kann es eigentlich nicht liegen, weil die betankung und konfiguration bei uns automatisch erfolgt.
    Ich persönlich vermute nun, dass genau in der Nacht ein Patch gekommen ist, welches in den BITS- oder Win-Update-Dienst eingegriffen hat. Da die Clients damals noch auf Auto-Update standen, könnten sich in jener Nacht einige den Fehler gezogen haben. Theoretisch jedenfalls.

    Diesbezüglich habe ich schon nach Infos gesucht, aber nix gefunden. Ich hatte gehofft, dass dieses Forum darüber mehr weiß ...

    na gut, werde den Thread noch ein paar tage offen lassen.
    vielleicht erinnert sich ja jemand, mit einem ähnlichen problem schon mal gekämpft zu haben.

    mfg
    mikebirth

    PS: gut möglich, dass wir ab freitag einen externen consultant suchen, der sich der sache annimmt. bei interesse bitte melden.
     
  7. Im fraglichen Zeitraum gibt es kein von MS für Windows XP releasetes Update - mit Ausnahme eines optionalen Stammzertifikate-Updates, siehe auch http://patch-info.de/artikel/2007/02/27/337
    Anyway, Du solltest dann Hinweise in der windowsupdate.log im Windows-Ordner finden können, zusätzlich evtl. eine weitere LOG-Datei für das vermutete Update.

    Bye,
    Freudi
     
  8. ok, problem ist immer noch da.
    trotzdem vielen Dank an alle, die mitgegrübelt haben, besonders natürlich @Freudi.
    mfg
    mikebirth
     
  9. Was hast Du denn konkret unternommen? Was ist mit der Firewall, dem AutoUpdate-Dienst und was mit dem Stammzertifikatsupdate?

    Mein ja nur,
    FreuMan sieht die Rechenknechte von hier aus so schlecht ;)di
     
Die Seite wird geladen...

extrem hohe Netzwerklast durch BITS - Ähnliche Themen

Forum Datum
lsass.exe & svchost.exe - ständig extrem hohe CPU-last Windows XP Forum 19. Apr. 2009
TB lässt sich extrem viel Zeit beim Mailabruf E-Mail-Programme 11. Sep. 2016
Wie 2 GK per CrossFire an ASRock 870 Extreme3 betreiben Hardware 15. Dez. 2015
Extreme Maus-Lags unter Windows 10 Windows 10 Forum 18. Okt. 2015
Firefax bei Facebook extremst langsam Web-Browser 22. Mai 2015